Author settings not saved.
Avatar
I am not sure if this is a bug, but whenever I read a chapter, and click next, settings are saved and fine. but once I go back to the main menu of the manga and click on a chapter again, the settings go back to single page, left to right and 3 pages load. Tried logging out and in again, but that didn't work. Might be someting with my browser, who knows..
Plykiya
Public Relations
Avatar
@WoodyCyber Are you on PC or mobile?
Avatar
sorry, forgot to add that. I am on PC.
Plykiya
Public Relations
Avatar
The settings are saved in your cookies. Do you have any add-ons or extensions that clear cache/cookies/localstorage?

Last edited 7 days ago by Plykiya.

Avatar
I checked browser settings under "remove browser data", and the "cookies and data" thing is turned off. Actually, I also just did a reboot of my PC, and that fixed it, somehow.
Avatar
Not all settings are saved in cookies (e. g. site background, language settings and many more), but some are saved in cookies. I'd also appreciate to save settings in your database instead of cookies, if possible.

same problem as in my thread:http://mmorpg-pay.info/thread/30163

Last edited 7 days ago by monkey123.

Plykiya
Public Relations
Avatar
@Monkey123 Switching from database to cookies was intentional, saving it in our database isn't on our priority list

Last edited 6 days ago by Plykiya.

Avatar
In case your using Firefox, might want to check this bug
http://bugzilla.mozilla.org/show_bug.cgi?id=1453699
as well.
If you left this setting at default, you should be fine, but if you changed it, there is a good chance Firefox will treat localstorage as session storage. Meaning every tab has different storage, and storage may be cleared when you leave the site. Supposedly will be fixed when they finalize the new storage system written for quantum.

Has been causing me hell for a while. If this is the case, it's a browser bug. Probably will be a few more months before the new system goes in place as well.

Last edited 6 days ago by firefish5000.

Teasday
Developer
Avatar
@firefish5000 posted:

http://bugzilla.mozilla.org/show_bug.cgi?id=1453699

Hadn't heard of this, good to know. 👀